Web Push

This public forum is for user-to-user discussions of ASP.NET Maker. Note that this is not support forum.
Post Reply
crash
User
Posts: 131

Web Push

Post by crash »

When I go to my subscription page I choose the subscribers to send the message... but then the system says no subscribers selected.
Even when I select all.
It then says ok send to all... I say yes and send and again it says no subscribers selected.
How do I fix this.
Thanks


MichaelG
User
Posts: 1049

Post by MichaelG »

Double check your settings according to:
https://aspnetmaker.dev/docs/#/webpush.html

Also press F12 -> Console and check for any JavaScript error in the page.


crash
User
Posts: 131

Post by crash »

The settings are correct… I do get some web socket errors.. no idea how to fix this.. says error says doc not complied correctly


Marijn
User
Posts: 4

Post by Marijn »

Hi, i am also busy with the web push funtion. I do not have the issue where it says "no subscribers selected" but it says "No subscriptions found". I get this issue by doing the following:

  • i added a subscription in the Subscriptions tab.
  • I try to send a notification with the administrator account.
  • When i try to send the notification i get the "No subscriptions found"error.

Does anybody know how to fix this?
Thanks already.


MichaelG
User
Posts: 1049

Post by MichaelG »

i added a subscription in the Subscriptions tab

You cannot add subscription on behalf of the actual user. The user should click the "Enable notification" button on the top right corner of the web site to add to the subscription table.


crash
User
Posts: 131

Post by crash »

My problem still persists.. ASPM says send to all subscribers.. then after I push yes I get msg.. no subscribers found.

The subscribers are in the list... on inspection I see websocket error


MichaelG
User
Posts: 1049

Post by MichaelG »

Make sure that the users have enabled the subscription correctly as in:
https://aspnetmaker.dev/docs/#/webpush. ... ifications


Marijn
User
Posts: 4

Post by Marijn »

I have a problem, where if i click as an user on enable notifications and allow it doesn't show up on the notifications table, like the tutorial shows of asp.net. i tried looking with administrator. I can only add them manually to the subscriber table, but this doesn't work. It says then "subribers not found".


MichaelG
User
Posts: 1049

Post by MichaelG »

Press F12 in your browser:

  1. Go to the Console panel to check for JavaScript errors,
  2. Go to the Newtork panel and check the HTTP response from the server, see if there are any server side errors.

crash
User
Posts: 131

Post by crash »

This function is still not working.. I have inspected and test no errors
When I select subscribers and then try notification the pop message just says no subscribers selected.

Thanks


crash
User
Posts: 131

Post by crash »

Correction it says No subscriptions found.
All fields are filled in for the subscriber I select.
Thanks


MichaelG
User
Posts: 1049

Post by MichaelG »

Make sure that the users have enabled the subscription correctly as in Web Push Notification. Remove all records first and try again.


Marijn
User
Posts: 4

Post by Marijn »

Hi guys i have two issues with the webpush function:

  • When i try to send users a notification it says "No subscriptions found".
  • The default person that is allowed to send notifications is an administrator, but can i also make it that an user can send another user a notification

MichaelG
User
Posts: 1049

Post by MichaelG »

As per previous reply:

Make sure that the users have enabled the subscription correctly as in Web Push Notification. Remove all records first and try again.

Users with Administrative rights and CanPush permission should be able to send push notification.


Marijn
User
Posts: 4

Post by Marijn »

I have tried to remove all the records, i also have tried to remove the whole subscriptions table and add it back again. Nothing of this has worked, does anybody know a different solution for the "No subscriber found" error?


Webmaster
User
Posts: 9422

Post by Webmaster »

If you are a registered user, you can send your project file/database to the support email for checking and quicker resolution.


Post Reply